Mastodon WebFinger #374

Closed
opened 2023-11-07 13:45:28 +01:00 by AntoineD · 1 comment
Member

I wanted to test mastodon-redirector, which lets you load content from an external mastodon into your instance.

By configuring it with a mastodon instance, it works.
But with an iceshrimp instance, it doesn't work.

Would it be possible to implement authorize_interaction?
I have a feeling it's linked to something called WebFinger:
https://docs.joinmastodon.org/spec/webfinger/

I wanted to test [mastodon-redirector](https://github.com/bramus/mastodon-redirector), which lets you load content from an external mastodon into your instance. By configuring it with a mastodon instance, it works. But with an iceshrimp instance, it doesn't work. - I tested with this source url: https://mastodon.social/@Mastodon/111315000523591837 - It redirected me to: https://next.iceshrimp.dev/authorize_interaction?uri=https%3A%2F%2Fmastodon.social%2F%40Mastodon%2F111315000523591837 Would it be possible to implement `authorize_interaction`? I have a feeling it's linked to something called WebFinger: https://docs.joinmastodon.org/spec/webfinger/
AntoineD added the
backend
enhancement
labels 2023-11-07 13:45:28 +01:00
AntoineD added this to the (deleted) project 2023-11-07 13:45:28 +01:00
Owner

Duplicate of #270

Duplicate of #270
zotan closed this issue 2023-11-08 04:22:57 +01:00
AntoineD removed this from the (deleted) project 2023-11-08 13:12:51 +01:00
Sign in to join this conversation.
No milestone
No project
No assignees
2 participants
Notifications
Due date
The due date is invalid or out of range. Please use the format "yyyy-mm-dd".

No due date set.

Dependencies

No dependencies set.

Reference: iceshrimp/iceshrimp#374
No description provided.